<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":157,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81772303-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>PowerMizzou.com  -  Brandon Lee has plans far beyond football</title>
<meta content='PowerMizzou.com  -  Brandon Lee has plans far beyond football' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-366eb75293203adba06ca258e9807c72995d061cc229c00b5599f8fb4557074d.css" />


<script src="https://cdn.rivals.com/production/assets/lib-2c218050dad198426f2e9ad50588b8e7f779d699e9bbbd1fde5e701df92e3866.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-b3ca6e275ca8518af75e4b939346cba98b11ffc93056409a84b405b211e25713.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="9JM0q/YHP+B9GG9LSwKPrGk00VuGpYrxd0jiOzzieVqErCau5HtO1unBZ+SQbtDign3Hc5zvUAFQD799wP9VUg==" />
<script>
  (function () {
    'use strict';
  
    angular.module('rivals').factory('userPaths', function () {
      var basePath = "rivals.com";
  
      var siteUrl = function(subdomain) {
        if(subdomain === 'rivals') {
          return window.location.protocol + '//' + basePath;
        } else {
          return window.location.protocol + '//' + subdomain + '.' + basePath;
        }
      };
  
      var trendingThreads = function(baseUrl, forum) {
        return baseUrl + 'api/threads/' + forum + '/trending';
      };
  
      var publishingDashboardUrl = function(subdomain) {
        return siteUrl(subdomain) + '/publishing/contents';
      };
  
      var commitmentsRelativePath = function (page, year) {
        var url;
        if (!page || (page != 'rivals150' && page != 'basketball')) {
          url = "/commitments/football"
        } else {
          url = "/commitments/basketball"
        }
  
        return url + (year ? '/' + year : '');
      };
  
      var commitmentsPath = function (page, year) {
        return basePath + commitmentsRelativePath(page, year);
      };
  
  
      var apiV1RanksProspectsPath = function (rank_id) {
        return "/api/v1/ranks/:rank_id/prospects".replace(/\:rank_id/i, rank_id);
      };
  
      var editContentsPath = function (content_id) {
        return "/publishing/contents/:content_id/edit".replace(/\:content_id/i, content_id);
      };
  
      var apiV1RankPeoplePath = function (rank_id) {
        return "/api/v1/people/rank/:rank_id".replace(/\:rank_id/i, rank_id);
      };
  
      var apiV1ForecastGraphPath = function (prospect_id) {
        return "/api/v1/content/forecast_graph/:prospect_id".replace(/\:prospect_id/i, prospect_id);
      };
  
      return {
        adminHomePath: "/admin/home",
        highschoolApiPath: "/api/v1/content/highschools",
        apiV1BreakingNewsPath: "/api/v1/breaking_news",
        apiV1ContentCollegesPath: "/api/v1/content/colleges",
        apiV1ContentContentsPath: "/api/v1/content/contents",
        apiV1ContentHighschoolsPath: "/api/v1/content/highschools",
        apiV1CustomModules: "/api/v1/custom_modules",
        apiV1CustomModulesPath: "/api/v1/custom_modules/id",
        apiV1EventsPath: "/api/v1/events",
        apiV1FavoriteBlocksPath: "/api/v1/publishing/favorite_blocks",
        apiV1FlipperShowPath: "/api/v1/flipper?key=key",
        apiV1ForecastGraphPath: apiV1ForecastGraphPath,
        apiV1GalleriesPath: "/api/v1/galleries",
        apiV1HpCustomModules: "/api/v1/hp_custom_modules",
        apiV1HpEnrichments: "/api/v1/hp_enrichments",
        apiV1ImagesPath: "/api/v1/images",
        apiV1ProspectRankingsPath: "/api/v1/prospect_rankings",
        apiV1RankPeoplePath: apiV1RankPeoplePath,
        apiV1RanksProspectsPath: apiV1RanksProspectsPath,
        apiV1TrendingContentsPath: "/api/v1/trending_contents",
        apiV1UsersPath: "/api/v1/users",
        basePath: basePath,
        commitmentsPath: commitmentsPath,
        commitmentsRelativePath: commitmentsRelativePath,
        contentsPath: "/news/slug",
        editContentsPath: editContentsPath,
        forumsPath: "https://missouri.forums.rivals.com/",
        forumsStatisticsPath: "",
        galleriesPath: "/galleries",
        homepagePath: "/content/sport",
        newUserRegistrationPath: "/sign_up",
        newSiteSubscriptionPath: "/subscriptions/new",
        prospectApiPath: "/api/content/prospects",
        prospectCardPath: "/content/prospect_cards/id",
        prospectsPath: "/content/prospects/id",
        publishingDashboardUrl: publishingDashboardUrl,
        registerPath:  "/sign_up",
        rivals250Path: "/prospect_rankings?sport=rivals250",
        signInPath:  "/users/sign_in",
        signOutPath:  "/users/sign_out",
        siteUrl: siteUrl,
        subscribePath: "/users/subscriptions",
        trendingThreads: trendingThreads,
        userProfileEditPath: "/users/profile",
        userProfilePath: "/users/profile"
      };
    });
  }).call(this);
</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/h2qwkaseruus9xvu1jwg' property='og:image'>
<meta content='Brandon Lee is a starting linebacker on the football field. What he does off of it is what sets the Mizzou senior apart.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-08-30 05:00:00 -0500' property='article:published_time'>
<meta content='2018-08-30 05:00:38 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "missouri.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='missouri contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .missouri #programming > h1 {
      background-color: #000000 !important; } }
  .missouri > header .notification-link .count-container {
    background-color: #000000 !important; }
  .missouri > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .missouri > header .wrapper-container {
        border-bottom: 5px solid #d0b00f !important; } }
  .missouri > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .missouri > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .missouri > header .invalid-email-banner a:hover {
      color: #d0b00f; }
  @media screen and (max-width: 767px) {
    .missouri > header .mobile-header {
      background-color: #d0b00f !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .missouri > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .missouri > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .missouri > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .missouri > header .nav-row > ul,
    .missouri > header .third-nav {
      background-color: white !important; }
    .missouri > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .missouri > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #d0b00f; }
  
  .site-secondary-background-color {
    background-color: #d0b00f; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #d0b00f; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Missouri" class="school-header" href="https://missouri.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/uuzmzcpvh6on5r9ofhli" alt="Uuzmzcpvh6on5r9ofhli" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://missouri.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;missouri&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://missouri.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;missouri&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733119,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Brandon Lee has plans far beyond football"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='GabeDeArmond' name='twitter:site'>
<meta content='Brandon Lee has plans far beyond football' name='twitter:title'>
<meta content='Brandon Lee is a starting linebacker on the football field. What he does off of it is what sets the Mizzou senior apart.' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2qwkaseruus9xvu1jwg' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":84,"legacy_id":898,"name":"PowerMizzou.com","friendly_name":"Missouri","annual_discount":null,"subdomain":"missouri","primary_color":"000000","secondary_color":"d0b00f","font_color":"ffffff","short_name":"missouri","maple_ncaaf_team_id":22,"maple_ncaaf_endpoint":"ncaaf/teams/mms","maple_ncaab_team_id":367,"maple_ncaab_endpoint":"ncaab/teams/mbh","maple_college_id":22,"google_analytics_id":"UA-81772303-1"}, true, 200, nil, {"id":127,"primary_color":"000000","secondary_color":"d0b00f","font_color":"ffffff","commitment_module_football":false,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"uuzmzcpvh6on5r9ofhli","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81772303-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":84,"created_at":"2016-11-23T13:38:44.328-06:00","updated_at":"2018-06-04T12:52:52.329-05:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://missouri.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5963e3e8b90afb5c991cffa6","aol_company_id":"595e57be2a30cb7ee3e53926","ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true},&#x000A;"5963e3e8b90afb5c991cffa6", "595e57be2a30cb7ee3e53926", "rivals", 15000)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":333,"image_id":2223121,"url":"http://shilohbar.com/","position":1,"site_id":84,"created_at":"2018-06-04T12:55:28.648-05:00","updated_at":"2018-06-04T12:55:28.648-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/mqnaob7fg9u3uw7ivhfn"}' class='ad-one'></rv-custom-ad>

<rv-homepage-forums ad-referer='https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football' background-color='#000000' base-api-url='https://missouri.forums.rivals.com/' homepage='false' message-board-url='https://missouri.forums.rivals.com' pub-ad='null' size='size' space-id='2022733119' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football/printable' site-name='PowerMizzou.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-08-30 05:00:00 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1953308/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Brandon Lee has plans far beyond football</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Gabe DeArmond
&bull;
</span>
<span class='type-sm'>PowerMizzou.com</span>
<div class='type-sm'>
<a href='//twitter.com/GabeDeArmond' target='_blank'>@GabeDeArmond</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/GabeDeArmond'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Gabe has covered the Tigers for PowerMizzou.com since August of 2003 and been the site's publisher since 2006.
</div>
</div>
</div>
<div class='mobile-links' ng-cloak ng-if='isMobile'>
<div class='article-subheader'>
Related
</div>
<slick in-view='isInView($inview)' settings='slickConfig'>
<div ng-repeat='link in [{"id":8035,"url":"https://missouri.rivals.com/news/2018-tiger-mailbag-34th-edition","display_text":"This Week&#x0027;s Mailbag","content_id":1953308,"created_at":"2018-08-29T11:54:37.235-05:00","updated_at":"2018-08-29T11:54:37.235-05:00","setting_id":null,"ordinality":1},{"id":8036,"url":"https://missouri.rivals.com/news/holmes-eager-to-move-past-injury-that-cost-him-last-season","display_text":"Christian Holmes eager to return","content_id":1953308,"created_at":"2018-08-29T11:54:37.238-05:00","updated_at":"2018-08-29T11:54:37.238-05:00","setting_id":null,"ordinality":2},{"id":8037,"url":"https://missouri.rivals.com/news/week-one-depth-chart-analysis","display_text":"Depth Chart Analysis","content_id":1953308,"created_at":"2018-08-29T11:54:37.240-05:00","updated_at":"2018-08-29T11:54:37.240-05:00","setting_id":null,"ordinality":3}]'>
<a ng-href='{{link.url}}' target='_blank'>{{ link.display_text }}</a>
</div>
</slick>
</div>
<div class='desktop-links' ng-cloak ng-if='!isMobile'>
<div class='article-subheader'>
Related
</div>
<span ng-repeat='link in [{"id":8035,"url":"https://missouri.rivals.com/news/2018-tiger-mailbag-34th-edition","display_text":"This Week&#x0027;s Mailbag","content_id":1953308,"created_at":"2018-08-29T11:54:37.235-05:00","updated_at":"2018-08-29T11:54:37.235-05:00","setting_id":null,"ordinality":1},{"id":8036,"url":"https://missouri.rivals.com/news/holmes-eager-to-move-past-injury-that-cost-him-last-season","display_text":"Christian Holmes eager to return","content_id":1953308,"created_at":"2018-08-29T11:54:37.238-05:00","updated_at":"2018-08-29T11:54:37.238-05:00","setting_id":null,"ordinality":2},{"id":8037,"url":"https://missouri.rivals.com/news/week-one-depth-chart-analysis","display_text":"Depth Chart Analysis","content_id":1953308,"created_at":"2018-08-29T11:54:37.240-05:00","updated_at":"2018-08-29T11:54:37.240-05:00","setting_id":null,"ordinality":3}]'>
<a class='type-sm' ng-href='{{link.url}}' target='_blank'>
{{ link.display_text }}
</a>
<span class='link-divider' ng-if='!$last'>
|
</span>
</span>
</div>

<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><a href="https://missouri.rivals.com/sign_up">GET THE INSIDE SCOOP EVERY DAY WITH YOUR PREMIUM SUBSCRIPTION!</a></p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Let’s get one thing straight to start: Like most seniors who play major college football, <b>Brandon Lee </b>hopes to be playing professionally next year.</p><p>“It’s always been a dream of mine to play in the National Football League,” the Missouri senior linebacker said. “That would be a main focus point of mine.”</p><p>At 6-foot-2, 225 pounds with 84 tackles over the last three seasons and 36 games played coming into this year, Lee has the credentials to give himself a chance at the NFL.</p><p>“I think he’s got a chance to play football past this year,” Tigers’ head coach <b>Barry Odom</b> said. “I really do. He’s a talented kid.”</p><p>“It would not surprise me,” said <b>Jed Richman</b>, who coached Lee in his final year-and-a-half at Lawrence Central High School before moving on to neighboring Pendleton Heights. “He’s the kind of kid--well, man, now--that whatever he puts his mind to he’s not going to sell himself short of that. He’s going to do everything in his power to make it happen. I think he has the ability.”</p><p>But athletes are always told to have a backup plan. Some of them actually do. Lee’s backup plan is strong enough that it just might become his primary plan. Lee graduated with a finance degree last May. While he’s playing his senior season, he’s also in his first semester of progressing toward a Master’s in Business Administration.</p><p>“I’ve come to the point of kind of wanting to be a financial advisor,” Lee said. “But throughout the MBA program, I’ll venture into a lot of different things and different routes that I could possibly take so I could see myself doing a lot of different things.”</p><p>“He’s a really sharp dude and I know he likes it a lot. He’s passionate about it,” fellow linebacker <b>Cale Garrett </b>said. “One of my roommates has already graduated, too, but he only has like two online classes. Brandon’s got work, online classes and all sorts of things, and I’m sitting over here just trying to graduate with a bachelor’s degree.”</p><p>“I’m not the sharpest knife in the drawer, so it’s kind of hard for me to put a scale on how smart he is,” outside linebackers coach <b>Brian Odom</b> said. “He’s smarter than I am, I know that.”</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2qwkaseruus9xvu1jwg)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2qwkaseruus9xvu1jwg" alt="H2qwkaseruus9xvu1jwg" />
</div>
<figcaption class='image-caption'>Lee is slated to start at strongside linebacker for the Tigers</figcaption>
<div class='image-credit'>Liv Paggiarino</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Lee has worked his class schedule mostly around football. Now and then he has to leave practice just a little bit early and he has to work things around night classes.</p><p>“Since he was a finance major, he took probably a little bit different classes than a normal football player, so this is not a new road that we’re driving with him,” <b>Brian Odom</b> said. “Brandon and I have always been able to sit down and watch film. He’s kind of a film rat in the fact that I’ll never be concerned with him not knowing what’s going on just because of how much film he watches on his own.”</p><p>Lee downplays the difficulty of juggling football and graduate classes.</p><p>“The only different part is the classes take place at different times,” he said. “But so far, they’re really not too much more difficult than the undergrad classes. The one other difference would be there’s only about 11 students in each of my classes.”</p><p>Lee has interned with Edward Jones and spent the last two summers with Krilogy Financial, a financial services firm in St. Louis. The President and CEO of Krilogy is <b>Kent Skornia</b>, who played quarterback at Mizzou in 1995 and 1996 before finishing his career at Southern Illinois.</p><p>“They dive in pretty deep. We throw them right into the mix,” Skornia said. “He’s doing security analysis, retirement plan analysis, he did estate planning analysis for our advisers. He supported our senior wealth advisors in helping with client situations.</p><p>“The minute you meet Brandon, you know that he’s a really intelligent person and he can handle a lot of things that are thrown at him.”</p><p>The MBA program at Mizzou generally takes two years to complete. Lee said he could potentially finish in a year-and-a-half, but by that time he hopes to be playing professional football. If that’s the case, the Master’s will be put on hold, but it will not be put on the shelf.</p><p>“That’s a personal goal of mine,” Lee said of finishing the graduate degree. “It’s bigger than just getting my Master’s. It’s changing the standard back at home for those who look up to me. Whether it’s those that are looking from the shadows that I don’t know, or my nieces and nephews, my younger cousins, all my family members — I’ve got a ton — so it’s just changing the standard. A lot of people from the inner city of Indianapolis don’t believe that you’re supposed to go on and get your Master’s. They don’t view it as necessarily a thing. They just want to go to college and get done as fast as they can. I want to change that viewpoint up.”</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/zpch9phijinbpp2ysbh1)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/zpch9phijinbpp2ysbh1" alt="Zpch9phijinbpp2ysbh1" />
</div>
<figcaption class='image-caption'>Lee visited Cal and Virginia Tech in addition to Missouri as a senior out of Lawrence Central</figcaption>
<div class='image-credit'>Rivals.com</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Lee has made a career of changing the viewpoint of a typical college athlete. He’s not just a graduate student. He serves on the Student Athletic Advisory Council at Mizzou. He has attended NCAA meetings with academic personnel from the university. This spring, he was the only athlete from Mizzou selected to attend the SEC spring meetings in Destin, Fla.</p><p>“Being around so many great coaches, so many great administrators, the athletic director and (SEC commissioner) Mr. <b>(Greg) Sankey</b>, it was just a great experience,” Lee said. “We kind of took part and we had certain votes as student athletes which is pretty cool and it was cool to see that our votes actually showed up. It wasn’t like they were just saying, ‘Oh yeah, we hear the athletes’ and wipe it under the rug.’”</p><p>“What he’s doing is really remarkable,” Skornia said. “Challenging yourself to do something at that level on both football and the academic side is really respectable. He’s a very driven young man. It’s for sure shown on the football field, but I would say it’s even more powerful off the football field.</p><p>“It’s not like he’s a fourth-stringer just sitting on the sidelines. He’s a leader on that team.”</p><p>Lee was one of just two football players at the SEC meetings, along with a long snapper from LSU. </p><p>“That’s a great honor, being a kid from Indianapolis and representing an entire different state as a whole and their University,” Lee said. “I’m very honored to do that and appreciative of that. I’m so thankful for it.”</p><p>“I think he’s a great role model for all the other guys to get it done,” said Mizzou running backs coach <b>Cornell Ford</b>, who recruiting Lee out of Lawrence Central in Indianapolis. “Good football player, but he’s all about business and understands that there’s life after football. </p><p>“Everything he’s done here in college, I expected.”</p><p>“He’s a better person than he is a football player and he’s an awful good football player,” Richman said. “I really mean this when I say it, I’ve got two little boys and if they can be like him, I’m gonna strike gold. Brandon’s parents are tremendous people and the apple doesn’t fall from the tree."</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/io42uzsp7i4sqo0nqtov)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/io42uzsp7i4sqo0nqtov" alt="Io42uzsp7i4sqo0nqtov" />
</div>
<figcaption class='image-caption'>Lee had a career-high 42 tackles and returned an interception for a touchdown in nine starts last season</figcaption>
<div class='image-credit'>Jordan Kodner</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>As a fifth-year senior, Lee is not only one of Missouri’s leaders on the field, but an example the Tiger coaches hold up to others off of it.</p><p> “You never hear about him doing anything really wrong,” defensive coordinator <b>Ryan Walters</b> said. “He doesn’t show up on any of the academic reports or anything like that. Whenever he is on there, it’s for something positive. He’s always doing, whether it’s an internship or community service or student advisory committee, he’s a leader that way.”</p><p>“We talk about it and we sell it,” Ford said. “You can graduate in four years and, if you do it right, your fifth year the University of Missouri is going to pay for your graduate school. Not all of them take advantage of it because not all of them are capable of taking advantage of it because it’s so challenging. He’s one of those young men that’s got his head on right and was up for the challenge.”</p><p><b>Brian Odom </b>recruited and signed four high school linebackers in the Class of 2018. He talked about one guy when he was recruiting them all: <b>Brandon Lee</b>.</p><p>“He’ll be a four-time letterman, he’s going to get his degree and he’s going to start on his MBA in the finance area. When you look at it on paper like that, it’s like, could you draw it up any better?” Odom said. “If people really sit down and think about what he’s done since he’s been at Mizzou…it’s really, really impressive. And I don’t know if he does get enough credit for that.”</p><p>There may be much bigger and better things than football in Lee’s future.</p><p> “I think he’s smart enough to know that the NFL is a once in a lifetime opportunity so he’s going to go after it and I don’t blame him. He’s also not so naive to not realize that the NFL’s not around forever,” Skornia said. “He approaches life the way you want. If my children grow up to be as successful as he is, you’d certainly be very, very proud.</p><p>"When you meet Brandon, he's a guy you want on your team."</p><p>“I’m really, really proud of him,” <b>Barry Odom</b> said. “You look at the way you want guys to take care and take advantage of opportunities that are out there, he could write the book on that.”</p><p>But for now, he’s got a season to play. And with kickoff two days away, Lee’s focus is on the field.</p><p>“The best part is you finally get to hit somebody with the intentions to hurt them,” he said. “I mean, I don’t want to hurt nobody, I don’t wish bad luck on them, but you get to tackle somebody with the intentions to physically hurt them and get to use all your capabilities that you’ve been working on all offseason. So I’m pretty excited about the season being here.”</p><p>Down the road, it may be <b>Brandon Lee</b>: MBA, Financial Advisor. </p><p>“For sure he’ll be handling my finances in the near future,” Garrett said. </p><p>For the next four months, though, it’s just <b>Brandon Lee</b>: Strong Side Linebacker.</p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football/printable' site-name='PowerMizzou.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' site='{"id":84,"legacy_id":898,"name":"PowerMizzou.com","friendly_name":"Missouri","annual_discount":null,"subdomain":"missouri","primary_color":"000000","secondary_color":"d0b00f","font_color":"ffffff","short_name":"missouri","maple_ncaaf_team_id":22,"maple_ncaaf_endpoint":"ncaaf/teams/mms","maple_ncaab_team_id":367,"maple_ncaab_endpoint":"ncaab/teams/mbh","maple_college_id":22,"google_analytics_id":"UA-81772303-1"}' twitter-feed='{"id":84,"site_id":84,"handle":"GabeDeArmond","list_name":"PowerMizzou-Staff","created_at":"2016-02-01T12:25:08.704-06:00","updated_at":"2018-03-26T06:33:00.263-05:00","hashtags":[],"usernames":["MizzouShowMe","Coach_Odom","MizzouFootball","MizzouHoops","CuonzoMartin"],"max_number":5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football/printable' site-name='PowerMizzou.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733119', 'https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Brandon Lee has plans far beyond football";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":333,"image_id":2223121,"url":"http://shilohbar.com/","position":1,"site_id":84,"created_at":"2018-06-04T12:55:28.648-05:00","updated_at":"2018-06-04T12:55:28.648-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/mqnaob7fg9u3uw7ivhfn"}' class='ad-one'></rv-custom-ad>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://missouri.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733119",
    c7: "https://missouri.rivals.com/news/brandon-lee-has-plans-far-beyond-football"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fmissouri.rivals.com%2Fnews%2Fbrandon-lee-has-plans-far-beyond-football&c5=2022733119&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
